XE 3.0.6 릴리즈 노트 (2019/10/14) > 소식통

본문 바로가기

사이트 내 전체검색

소식통

XE 3.0.6 릴리즈 노트 (2019/10/14)

작성일 19-10-17 08:07

페이지 정보

작성자아이웹스쿨넷 조회 248회 댓글 0건

본문

XpressEngine입니다.


아침과 저녁으로 일교차가 심한 날이 계속되고 있습니다,

감기 걸리시지 않게 유의하시고, 따듯하며 포근한 하루가 계속되길 기원하겠습니다.


10월 14일, XE 3.0.6 버전 에서 아래와 같은 기능 개선, 버그 수정이 진행되었습니다.

여러분들의 다양한 피드백과, 제안을 부탁드립니다 :)


4fdeb01721cb16f1238fde3f09885e8b_1571267222_2842.jpg
 


개선 사항

다국어 데이터가 많은 경우 캐시 재생성 성능 개선 #1040

도메인을 기반으로 한 locale처리시 세선 공유 개선 #1049

captcha설정이 없을때 회원 기본 설정이 되지 않던 문제 개선 #1033

SEO 처리시 검색엔진에서 Description부분이 정상적으로 수집되지 않던 문제 해결 #1048

IE에서 스크립트 오류가 발생하는 문제 해결 #8264961

주소타입의 확장 필드를 검색시 컬럼이 존재하지 않던 문제 해결 #1031 

boolean타입 등의 확장 필드를 검색 했을때, 이전 필드의 값이 유지되지 않는 문제 해결 #1032

 


Core 업데이트 주의사항

SSH(터미널)환경에서 업데이트 하는 경우 업데이트 가이드를 참고하시기 바랍니다.

서비스 중인 사이트에 적용하시기 전에 서비스 중인 사이트와 유사한 환경을 갖추고 이상이 없는지 확인하시길 권고합니다.

업데이트 전 관리자 로그인 상태로 관리페이지를 열어두시고 진행하시길 권고합니다.

업데이트 후 플러그인들을 업데이트해야 합니다.

업데이트 후 캐시를 갱신하셔야 합니다.

업데이트 후 오류가 발생한다면 storage/app/interception 디렉토리에 있는 모든 파일들을 삭제하시기 바랍니다.

 


업데이트시 알아두세요

웹 업데이트 기능을 사용하기 위해서는 php binary가 사용 가능한지 확인해야 합니다.

SSH 프로그램(Putty 등)을 사용하여 서버에 접속후 " php -v " 명령을 실행하여, PHP의 버전 정보가 정상적으로 표시되는지 확인해주세요.

php binary가 사용 불가능한 환경이라면, cgi api (php-fpm)로 PHP가 구동되는지 확인해주세요.

php binary를 사용할 수 없으며, cgi api를 사용하는 환경에서는 정상적으로 업데이트가 실행되지 않을 수 있으니, 업데이트가 가능한 다른 서버 또는 로컬PC에서 FTP 등을 이용하여 서비스에 적용 후 이용하시기 바랍니다.

자동 업데이트는 소스파일이 변경되는 작업이 수행되기 때문에, 프로젝트 루트에 파일 쓰기 권한이 필요합니다.

꼭 루트의 파일 쓰기 권한 또는, php binary를 꼭 확인해주세요!!

 


더 알아보기

제작한 플러그인을 배포할 수 있는 XE Store에 방문해보세요!

XE3 가이드로 궁금한 점을 해결해보세요. API와 Front-End 문서도 준비되어 있어요!

XE3는 여러분의 기여를 기다리고 있습니다. Pull Request 작성 가이드를 확인해보세요!

체험하기 서비스로 새로워진 XE3를 복잡한 절차 없이 사용해보세요!

댓글목록

등록된 댓글이 없습니다.

Copyright © 소유하신 도메인. All rights reserved.
PC 버전으로 보기